The chrome rotor covers ...


Information and questions on GL1500 Goldwings (1988-2000)
Post Reply
User avatar
in2it
Posts: 146
Joined: Sun Oct 06, 2019 6:09 am
Location: Waldo,Arkansas
Motorcycle: 2000 GL 1500 Aspencade
1982 GL1100 (SOLD)
1980 GL1100 Bobber with Vance and Hines Mufflers (SOLD)

Past Rides in my youth
1965 Honda C102 50cc OHV Engine with 3spd Auto-Clutch
1972 CB 350
1975 CB 550 4 with Dunstall headers and mufflers
1978 GL 1000

The chrome rotor covers ...

Post by in2it »



The 2000 ASP front chrome rotor covers has the LED lights (so called ring of fire) in them one side is bright the right side other side left side is dim ... there not nearly as bright as the right side... just asking what to look for before I tear into tracing wires that the PO has done or didn't do... was thinking maybe a bad ground but that would affect both of them and not just one... right??? ... has anyone have this happen to them ??? .. thanks in advance for any and all advice



Crusty1
Posts: 40
Joined: Sat Jun 06, 2020 10:57 am
Location: Kansas
Motorcycle: 2000 GL1500SE
2007 ST1300A ABS

Re: The chrome rotor covers ...

Post by Crusty1 »

My ring of fire were dim and the whole strip was coming un glued from the cover. Used a heat gun to soften the adhesive and pulled them out. Cleaned the brake dust and grime with alcohol. Bought some 3m 2 sided adhesive tape and reinstalled them. Good as new.

User avatar
Charlie1Horse
Posts: 573
Joined: Mon Sep 16, 2013 9:35 pm
Location: Jacksonville, Florida
Motorcycle: 1986 GL1200A Aspencade
1992 GL1500I Interstate

Re: The chrome rotor covers ...

Post by Charlie1Horse »

If they work at all they must have 12V+ and 12V- and they should work the same on both sides. LEDs do go bad sometimes and I would think that that is what has happened here. Of course, it wouldn't do any harm to test the wiring connections and make sure that there are no frayed wires but, I think you will have to replace them. I have some LEDs on the side of my 92 Interstates saddlebags and one side has gotten dim over time. I know mine are defective and will have to change them.
Russell

If I don't do Facebook or Twitter, do I still have to do Social Media Distancing????
Those who say it cannot be done should try not to interrupt those who are doing it.

User avatar
CrystalPistol
Posts: 1402
Joined: Wed Mar 10, 2010 9:07 pm
Location: Shenandoah Valley of Virginia
Motorcycle: 1997 GL1500SE/'98 Lehman Trike

Re: The chrome rotor covers ...

Post by CrystalPistol »

in2it wrote:
Fri Oct 16, 2020 8:13 pm
The 2000 ASP front chrome rotor covers has the LED lights (so called ring of fire) in them one side is bright the right side other side left side is dim ... there not nearly as bright as the right side... just asking what to look for before I tear into tracing wires that the PO has done or didn't do... was thinking maybe a bad ground but that would affect both of them and not just one... right??? ... has anyone have this happen to them ??? .. thanks in advance for any and all advice
Depends if they are grounded together on one pigtail (spliced) or separately?
Make Courtesy your "Code of the Road" …

… & Have a Safe Trip!
:)

User avatar
in2it
Posts: 146
Joined: Sun Oct 06, 2019 6:09 am
Location: Waldo,Arkansas
Motorcycle: 2000 GL 1500 Aspencade
1982 GL1100 (SOLD)
1980 GL1100 Bobber with Vance and Hines Mufflers (SOLD)

Past Rides in my youth
1965 Honda C102 50cc OHV Engine with 3spd Auto-Clutch
1972 CB 350
1975 CB 550 4 with Dunstall headers and mufflers
1978 GL 1000

Re: The chrome rotor covers ...

Post by in2it »

Crusty1 wrote:
Fri Oct 16, 2020 8:48 pm
My ring of fire were dim and the whole strip was coming un glued from the cover. Used a heat gun to soften the adhesive and pulled them out. Cleaned the brake dust and grime with alcohol. Bought some 3m 2 sided adhesive tape and reinstalled them. Good as new.
Will look into that ... thank you for the advice

User avatar
in2it
Posts: 146
Joined: Sun Oct 06, 2019 6:09 am
Location: Waldo,Arkansas
Motorcycle: 2000 GL 1500 Aspencade
1982 GL1100 (SOLD)
1980 GL1100 Bobber with Vance and Hines Mufflers (SOLD)

Past Rides in my youth
1965 Honda C102 50cc OHV Engine with 3spd Auto-Clutch
1972 CB 350
1975 CB 550 4 with Dunstall headers and mufflers
1978 GL 1000

Re: The chrome rotor covers ...

Post by in2it »

Charlie1Horse wrote:
Fri Oct 16, 2020 8:55 pm
If they work at all they must have 12V+ and 12V- and they should work the same on both sides. LEDs do go bad sometimes and I would think that that is what has happened here. Of course, it wouldn't do any harm to test the wiring connections and make sure that there are no frayed wires but, I think you will have to replace them. I have some LEDs on the side of my 92 Interstates saddlebags and one side has gotten dim over time. I know mine are defective and will have to change them.
Russell

If I don't do Facebook or Twitter, do I still have to do Social Media Distancing????
Will check this for sure... today the weather is going to be good and going to dive into this and see... for they use to be bright and check on pricing on a new set just in case

User avatar
in2it
Posts: 146
Joined: Sun Oct 06, 2019 6:09 am
Location: Waldo,Arkansas
Motorcycle: 2000 GL 1500 Aspencade
1982 GL1100 (SOLD)
1980 GL1100 Bobber with Vance and Hines Mufflers (SOLD)

Past Rides in my youth
1965 Honda C102 50cc OHV Engine with 3spd Auto-Clutch
1972 CB 350
1975 CB 550 4 with Dunstall headers and mufflers
1978 GL 1000

Re: The chrome rotor covers ...

Post by in2it »

CrystalPistol wrote:
Fri Oct 16, 2020 10:19 pm
in2it wrote:
Fri Oct 16, 2020 8:13 pm
The 2000 ASP front chrome rotor covers has the LED lights (so called ring of fire) in them one side is bright the right side other side left side is dim ... there not nearly as bright as the right side... just asking what to look for before I tear into tracing wires that the PO has done or didn't do... was thinking maybe a bad ground but that would affect both of them and not just one... right??? ... has anyone have this happen to them ??? .. thanks in advance for any and all advice
Depends if they are grounded together on one pigtail (spliced) or separately?
Exactly ... thats what I thinking also ...you just don't know what the po has done

User avatar
in2it
Posts: 146
Joined: Sun Oct 06, 2019 6:09 am
Location: Waldo,Arkansas
Motorcycle: 2000 GL 1500 Aspencade
1982 GL1100 (SOLD)
1980 GL1100 Bobber with Vance and Hines Mufflers (SOLD)

Past Rides in my youth
1965 Honda C102 50cc OHV Engine with 3spd Auto-Clutch
1972 CB 350
1975 CB 550 4 with Dunstall headers and mufflers
1978 GL 1000

Re: The chrome rotor covers ...

Post by in2it »

After looking at the problem... they are two lights in parallel one shining outside to the world the other shiny to the wheel, the one shiny to the wheel isn’t working ... so time for a replacement... I see Cyclemax sells them ... wish to thank everyone for the replies



Post Reply