ECM


Information and questions on GL1500 Goldwings (1988-2000)
Post Reply
glinjxn
Posts: 3
Joined: Mon Mar 08, 2021 12:38 pm
Location: Richland, Ms.
Motorcycle: 1997 gl1500 aspencade

ECM

Post by glinjxn »



Good day everyone,
I am working on a 1997 gl1500 and according to the service manual, the ECM is bad. Checked with Honda and they are no longer available. Does anyone know of a rebuilder of this type ECM? Any thoughts would be appreciated. Thanks.


User avatar
MikeB
Posts: 3526
Joined: Fri Dec 04, 2009 12:54 pm
Location: Tacoma, WA
Motorcycle: 1998 - GL1500 Aspencade
186K Miles
2017 - GL1800 Audio Comfort
20K Miles
Contact:

Re: ECM

Post by MikeB »

You might be money ahead to just find a used one on Ebay.
MikeB
1998 - GL1500 w/184,500 miles ~ 2017 - GL1800 w/13000 miles
USAF Avionics Communications Tech - 1968 - 1986 / Flight Engineer C-130E - C-141B - 1986 - 1992. Retired
Industrial Maintenance Tech - 1992 - 2014
Retired in Tacoma, WA
User avatar
Rambozo
Posts: 1084
Joined: Sun Apr 01, 2018 8:36 pm
Location: Disneyland
Motorcycle: 1992 GL1500 Aspencade
Ducati Monster

Re: ECM

Post by Rambozo »

Depending on what is wrong, if you search this forum, you can find info on repairing some of the more common faults in the ECM.
User avatar
MikeB
Posts: 3526
Joined: Fri Dec 04, 2009 12:54 pm
Location: Tacoma, WA
Motorcycle: 1998 - GL1500 Aspencade
186K Miles
2017 - GL1800 Audio Comfort
20K Miles
Contact:

Re: ECM

Post by MikeB »

Rambozo wrote: Wed Apr 14, 2021 5:47 pm Depending on what is wrong, if you search this forum, you can find info on repairing some of the more common faults in the ECM.
I have not seen anything here concerning ECM repairs, but I have nver had a need to find anything like that. Can you possibly point to one such possibility? I'm curious. I'd like to see what is involved.
MikeB
1998 - GL1500 w/184,500 miles ~ 2017 - GL1800 w/13000 miles
USAF Avionics Communications Tech - 1968 - 1986 / Flight Engineer C-130E - C-141B - 1986 - 1992. Retired
Industrial Maintenance Tech - 1992 - 2014
Retired in Tacoma, WA
Crusty1
Posts: 64
Joined: Sat Jun 06, 2020 10:57 am
Location: Kansas
Motorcycle: 2000 GL1500SE
2007 ST1300A ABS

Re: ECM

Post by Crusty1 »

glinjxn wrote: Wed Apr 14, 2021 1:48 pm Good day everyone,
I am working on a 1997 gl1500 and according to the service manual, the ECM is bad. Checked with Honda and they are no longer available. Does anyone know of a rebuilder of this type ECM? Any thoughts would be appreciated. Thanks.
ECM failures on the GL1500 are almost unheard of. If yours has indeed failed you have a very very good chance of finding a good used one. What sort of failure or problem are you chasing?
User avatar
AZgl1800
Posts: 2825
Joined: Thu Oct 30, 2008 2:46 pm
Location: Lake Oologah Indian Territory USA
Motorcycle: 2009 Piaggio MP3 250cc https://imgur.com/foGDjgv

'02 GL1800 lives in Dawsonville, GA now.
My son is going to enjoy it for many years to come.

Re: ECM

Post by AZgl1800 »

I used to have a link for repairing the transistor connections, but seems to have gone 404 :(
~John

2009 Piaggio MP3 250cc

https://i.imgur.com/4SOFPYS.jpg
User avatar
Rambozo
Posts: 1084
Joined: Sun Apr 01, 2018 8:36 pm
Location: Disneyland
Motorcycle: 1992 GL1500 Aspencade
Ducati Monster

Re: ECM

Post by Rambozo »

MikeB wrote: Wed Apr 14, 2021 6:27 pm I have not seen anything here concerning ECM repairs, but I have nver had a need to find anything like that. Can you possibly point to one such possibility? I'm curious. I'd like to see what is involved.
If the problem is that the fuel pump no longer gets a run signal, that can be caused by a bad switching transistor in the ECM.
viewtopic.php?p=72687#p72687
I seem to recall something similar for a coil problem, but am unable to locate that. Might have been a different forum?
User avatar
MikeB
Posts: 3526
Joined: Fri Dec 04, 2009 12:54 pm
Location: Tacoma, WA
Motorcycle: 1998 - GL1500 Aspencade
186K Miles
2017 - GL1800 Audio Comfort
20K Miles
Contact:

Re: ECM

Post by MikeB »

Rambozo wrote: Wed Apr 14, 2021 8:07 pm
MikeB wrote: Wed Apr 14, 2021 6:27 pm I have not seen anything here concerning ECM repairs, but I have nver had a need to find anything like that. Can you possibly point to one such possibility? I'm curious. I'd like to see what is involved.
If the problem is that the fuel pump no longer gets a run signal, that can be caused by a bad switching transistor in the ECM.
viewtopic.php?p=72687#p72687
I seem to recall something similar for a coil problem, but am unable to locate that. Might have been a different forum?
Good deal. Thanks. That was about 8 years ago. I didn't remember seeing it then and now that I know it exists, I can reference it. It figures that it was Virgil that did the work. That guy is amazing.
MikeB
1998 - GL1500 w/184,500 miles ~ 2017 - GL1800 w/13000 miles
USAF Avionics Communications Tech - 1968 - 1986 / Flight Engineer C-130E - C-141B - 1986 - 1992. Retired
Industrial Maintenance Tech - 1992 - 2014
Retired in Tacoma, WA
User avatar
DenverWinger
Posts: 1970
Joined: Thu Jun 23, 2011 2:20 pm
Location: Denver, CO
Motorcycle: (s)
1980 GL1100 STD Vetter (2005-)
1993 GL1500 Aspencade (2017-)
1983 Trav-Lite Camper (2010-)
Past rides
1972 CL350 (1980-1988) sold
1978 Suzuki GS550 (1985-2005) sold
1977 GL1000 (2002-2006) sold

Re: ECM

Post by DenverWinger »

It might help us recommend a fix if we knew exactly what the fault is... Post a picture of the page in the Service manual where it says faulty ECM, Circle the test step.
♫ 99 Little Bugs in the Code, ♪
♪ 99 Bugs in the Code. ♫ :(
♫ Take one down, Patch it around, ♪
♫ 127 Little Bugs in the Code. ♫ ♪ :shock:

~Mark
glinjxn
Posts: 3
Joined: Mon Mar 08, 2021 12:38 pm
Location: Richland, Ms.
Motorcycle: 1997 gl1500 aspencade

Re: ECM

Post by glinjxn »

it is described on pg 4-10 of the manual, can't copy and paste page from pdf. What you do is remove electrical connector from ECM, connect jumper wire from blk/wht and blk/blu wires. Turn on ignition switch for 5 seconds and measure amount of fuel flow. Multiply by 12 to get cc/min. 640 or more fuel pump ok. if fuel pump good then ECM faulty. Thanks to all for the help with this.
User avatar
Aisalord
Posts: 6
Joined: Tue Mar 02, 2021 7:23 am
Location: Ancona, Italy
Motorcycle: Honda Transalp PD06
Honda Gold Wing GL1500 SE '93

Re: ECM

Post by Aisalord »

Have you checked on Ebay?
These are the results with a "quick and dirt" search: https://www.ebay.com/b/Motorcycle-CDIs- ... n_19420308
User avatar
bellboy40
Posts: 917
Joined: Fri Nov 27, 2009 1:13 pm
Location: Brewton, AL
Motorcycle: 2000 GL1500SE Candy Spectra Red

Re: ECM

Post by bellboy40 »

What kind of trouble are you having with your bike? Those ECU units seldom fail. Not saying it can't be the cause, but they are very reliable.
User avatar
DenverWinger
Posts: 1970
Joined: Thu Jun 23, 2011 2:20 pm
Location: Denver, CO
Motorcycle: (s)
1980 GL1100 STD Vetter (2005-)
1993 GL1500 Aspencade (2017-)
1983 Trav-Lite Camper (2010-)
Past rides
1972 CL350 (1980-1988) sold
1978 Suzuki GS550 (1985-2005) sold
1977 GL1000 (2002-2006) sold

Re: ECM

Post by DenverWinger »

If the fuel pump does not run with the ECM connected and start button pressed (No power to pump unless engine is running or starter button pressed), but the pump does when you use the jumper in the ECM connector this indicates the ECM has a failed fuel pump output.

This is probably a blown output transistor, and this is REPAIRABLE, you don't need a new ECM.

Here's how to do it:
viewtopic.php?p=72687#p72687
♫ 99 Little Bugs in the Code, ♪
♪ 99 Bugs in the Code. ♫ :(
♫ Take one down, Patch it around, ♪
♫ 127 Little Bugs in the Code. ♫ ♪ :shock:

~Mark
User avatar
MikeB
Posts: 3526
Joined: Fri Dec 04, 2009 12:54 pm
Location: Tacoma, WA
Motorcycle: 1998 - GL1500 Aspencade
186K Miles
2017 - GL1800 Audio Comfort
20K Miles
Contact:

Re: ECM

Post by MikeB »

If you do not feel comfortable working on electronics, maybe contact virgilmobile and ask if he could check it out for you. As you can see in the linked post, he has some experience in this. And, he absolutley loves working on things. Send him a PM and ask. It couldn't hurt.
MikeB
1998 - GL1500 w/184,500 miles ~ 2017 - GL1800 w/13000 miles
USAF Avionics Communications Tech - 1968 - 1986 / Flight Engineer C-130E - C-141B - 1986 - 1992. Retired
Industrial Maintenance Tech - 1992 - 2014
Retired in Tacoma, WA
glinjxn
Posts: 3
Joined: Mon Mar 08, 2021 12:38 pm
Location: Richland, Ms.
Motorcycle: 1997 gl1500 aspencade

Re: ECM

Post by glinjxn »

Sent him a pm but have not had any response yet.


Post Reply