Is LCD burnt??


Information and questions on GL1500 Goldwings (1988-2000)
Post Reply
User avatar
gipsy42
Posts: 170
Joined: Sat Jun 12, 2010 8:58 pm
Location: Villa Adelina, Bs.As. Argentina
Motorcycle: 1995 GL1500 A Champion Trike
1993 GL1500 SE sold at 04/2021
1978 GL1000
Contact:

Is LCD burnt??

Post by gipsy42 »



Hi to all the gurus in the site.
This is to help a friend of mine with his ’93 Aspy, due to health issues the bike has been sitting garaged for more than 3 years, and now he’s back on the road but;
The LCD doesn’t come alive, no signal of any kind. I checked all fuses, actually replaced them all with new ones just in case.
Engine runs, radio, reverse, position ligths, turn signals, emergency, brakes, indicators lights all work, but by not having the LCD he can’t use the Auto Level Control, even when the compressor works in the outlet function.
I've been browsing the shop manual, and I’m at lost with this issue so and any idea/suggestion/lead to a solution will be very much appreciated.
Mario


Mario
aka Gipsy42
And still riding...
I just regrets the things I haven't done.

http://www.surfcam.com.ar
http://www.cre-angeles.org.ar
User avatar
bellboy40
Posts: 932
Joined: Fri Nov 27, 2009 1:13 pm
Location: Brewton, AL
Motorcycle: 2000 GL1500SE Candy Spectra Red

Re: Is LCD burnt??

Post by bellboy40 »

Did you check the #13 backup fuse? It is not with the other fuses but is in the relay box. Not sure that would cause this issue but it does go to the LCD unit. It could be just illumination for it.
User avatar
gipsy42
Posts: 170
Joined: Sat Jun 12, 2010 8:58 pm
Location: Villa Adelina, Bs.As. Argentina
Motorcycle: 1995 GL1500 A Champion Trike
1993 GL1500 SE sold at 04/2021
1978 GL1000
Contact:

Re: Is LCD burnt??

Post by gipsy42 »

Thank you.
No I ‘didn’t, I thought about it but discarded the idea because a week ago in another 1500 that fuse was blown and the LCD was working Ok, you may be right, I’ll check that fuse and report back.
Mario
aka Gipsy42
And still riding...
I just regrets the things I haven't done.

http://www.surfcam.com.ar
http://www.cre-angeles.org.ar
User avatar
aj1500
Posts: 457
Joined: Fri May 29, 2015 8:05 am
Location: Savannah Ga
Motorcycle: 02 ABS 1800
97 1500 SE
Motorvation II sidecar
Double Dark Side # 1522
Goodyear Fuel max 175/60 R16
PILOT ACTIV 130/70 18
USCA# 8913
96 Aspy 1500 W Lehmann trike

Re: Is LCD burnt??

Post by aj1500 »

I bought a 96 that had sat for about 3 years or more and had the same issue, however after about a week of riding it once I had it running it came back to life on it's own, Now if we let it sit a couple weeks the screen will be blank again until about the 3rd time it is restarted then other than the clock not keeping good time it works good
you may get lucky and it just come back on it's own like we did
User avatar
gipsy42
Posts: 170
Joined: Sat Jun 12, 2010 8:58 pm
Location: Villa Adelina, Bs.As. Argentina
Motorcycle: 1995 GL1500 A Champion Trike
1993 GL1500 SE sold at 04/2021
1978 GL1000
Contact:

Re: Is LCD burnt??

Post by gipsy42 »

bellboy40 wrote: Sun Nov 21, 2021 8:37 am Did you check the #13 backup fuse? It is not with the other fuses but is in the relay box. Not sure that would cause this issue but it does go to the LCD unit. It could be just illumination for it.
I went back to my friends house, and pulled both #12 and #13 fuses, both are Ok, and ilumination of it is also Ok. So I presume the LCD is burned out.
Will have to to take the whole cluster out to find out what's wrong.
Thank you all for the ideas.
Mario


Mario
aka Gipsy42
And still riding...
I just regrets the things I haven't done.

http://www.surfcam.com.ar
http://www.cre-angeles.org.ar
Post Reply