2002 GL1800 Reading radio display


Information and questions on GL1800 Goldwings (2001-2017)
Post Reply
User avatar
19Winger53
Posts: 4
Joined: Tue Jun 19, 2012 2:06 pm
Location: Den Helder, Noord-Holland, Netherlands
Motorcycle: 2002 GL1800

2002 GL1800 Reading radio display

Post by 19Winger53 »



Hello, I'm new in this forum and want to try to solve an problem. About two months ago I'll replaced the battery. After this replacement the reading of the radio information didn't function as normal. After the replacement I noticed that the radio information, e.g. witch station your listening to or the volume of the radio when changing wouldn't be displayed. Also the Intercom volume isn't on the display. All other readings as the Goldwing symbol when turning power on and of and open lid of a trunk wil be displayed, but the welcome or goodbye message isn't displayed. It seems that the "standard" readings wil be displayed and the "advanced" readings won't be displayed. Can anyone help me to solve this problem?


Kind regards,

19Winger53
ve5rus
Posts: 2
Joined: Mon Jul 02, 2012 8:57 am
Location: Lloydminster,sask
Motorcycle: 2004goldwing

Re: 2002 GL1800 Reading radio display

Post by ve5rus »

Not sure if I can help. I have a similar issue on my 2004. Neither my cb information or stereo information is being displayed. I am looking into the wiring diagrams in the clymer service manual for a reset function or common communication LCD driver wiring.

On mine the display obviously works as it displays all other info trunk open temp suspension and I can turn on the audio mode and set variables but doing it blind without the display. This occured after I changed the air filter. (major pain in the butt). I know they speak of the display mode button wiring plug but this appears to be something else.

Hello guru guys with wings. Is there something easy to check?

Russell
Fire engine red 04 estate sale special with christmas tree lighting and lots of chrome. lol
Bouvier1
Posts: 106
Joined: Tue Jul 27, 2010 4:09 pm
Location: United Kingdom
Motorcycle: 2007 Gl 1800A

Re: 2002 GL1800 Reading radio display

Post by Bouvier1 »

Have you both checked the Multi-display control switch connector. This has 4 pins and if one has been accidentaly pushed to a side when re-fitting I believe this can cause the type of problems you are having.
ve5rus
Posts: 2
Joined: Mon Jul 02, 2012 8:57 am
Location: Lloydminster,sask
Motorcycle: 2004goldwing

Re: 2002 GL1800 Reading radio display

Post by ve5rus »

Not sure what happened buit part way into my journey South side it started to work again. I will investigate the pin thing once home if the display gives me any more grief. Thanks
User avatar
19Winger53
Posts: 4
Joined: Tue Jun 19, 2012 2:06 pm
Location: Den Helder, Noord-Holland, Netherlands
Motorcycle: 2002 GL1800

Re: 2002 GL1800 Reading radio display

Post by 19Winger53 »

Bouvier1, I've checked the Multi-display control switch connector and discoverd no lose pins. I've cleaned the connector and after that still the same problem. My problem isn't caused because I've disconected the radio or some parts of the "cockpit". But it came after changing the battery. Thanks for your suggestion.
Kind regards,

19Winger53
Bouvier1
Posts: 106
Joined: Tue Jul 27, 2010 4:09 pm
Location: United Kingdom
Motorcycle: 2007 Gl 1800A

Re: 2002 GL1800 Reading radio display

Post by Bouvier1 »

Sorry Winger53,
I read both and obviously did not seperate them.
I would suggest that the 'quiet' button on the left handlebar is pressed in as this cuts out the other functions to do with the volume.
As you have replaced your battery the 'Welcome' will have to be reset.
User avatar
19Winger53
Posts: 4
Joined: Tue Jun 19, 2012 2:06 pm
Location: Den Helder, Noord-Holland, Netherlands
Motorcycle: 2002 GL1800

Re: 2002 GL1800 Reading radio display

Post by 19Winger53 »

Bouvier1, I'll think you mean the Mute switch. That button is not activated, volumecontrol of all the functions is no problem. The problem is actualy that I can't see the information of the volume, radiostation or other information in the display. The only information I'll see is the Wingsymbol when activate the power, information about lids that are not closed, outside temperature. That's what I mean by standard readings, all other readings are not visible.
Kind regards,

19Winger53
User avatar
MikeB
Posts: 3316
Joined: Fri Dec 04, 2009 12:54 pm
Location: Tacoma, WA
Motorcycle: 1998 - GL1500 Aspencade
184K Miles
2017 - GL1800 Audio Comfort
14K Miles
Contact:

Re: 2002 GL1800 Reading radio display

Post by MikeB »

Did either of you figure out what the problem was with your Multi display? How did you fix it if you figured it out?
MikeB
1998 - GL1500 w/184,500 miles ~ 2017 - GL1800 w/13000 miles
USAF Avionics Communications Tech - 1968 - 1986 / Flight Engineer C-130E - C-141B - 1986 - 1992. Retired
Industrial Maintenance Tech - 1992 - 2014
Retired in Tacoma, WA
User avatar
19Winger53
Posts: 4
Joined: Tue Jun 19, 2012 2:06 pm
Location: Den Helder, Noord-Holland, Netherlands
Motorcycle: 2002 GL1800

Re: 2002 GL1800 Reading radio display

Post by 19Winger53 »

I would like to thank all off you who has replied on this topic. In my vacationperiod I had checked al the wiring and find out that some of the connections on the battery where having corrosion on it. But also bad connections where noticed. After replacing some endparts of the wiring all functions seems to be normal.
That means that my problem has been solved. :P


Kind regards,

19Winger53
Post Reply