Page 1 of 1

troubleshooting left back speaker - no sound

Posted: Wed May 24, 2017 11:36 pm
by Toyman9
I have a 2008 Goldwing GL and can not find out how to open up the speaker area to see if the speaker went or the problem is somewhere else? Looking for anyone that might have some insight...
Thanks Gregg

Re: troubleshooting left back speaker - no sound

Posted: Thu May 25, 2017 8:32 am
by thrasherg
It is a pain in the arse to get to the speaker, the wire is probably damaged near the hinge of the top box.
To get to the speaker, there are 5 screws that hold the housing together, 4 of them are accessible from the outside of the top box, if you open the top box so the lid is vertical and the speakers are pointing at the floor, you should see 4 holes in the bottom of the black plastic speaker housing. They are regular cross head screws, so just unscrew them. There is a fifth screw, but it requires that you remove the liner in the lid of the top box/case. That means undoing ~16 screws, once you have removed the 16 screws, you then need to remove the 2 metal catches which lock the top case closed (2 screws on each catch) then the liner will come out, be aware the remote trunk opener electronics are mounted to the top of the liner so it won't come out far before the wires stop it. But once you have the liner loosened, you will see one more screw in the lid that hold the black plastic speaker housing in place, undo that screw and the speaker housing should come off, it will obviously still have a wire attaching it to the bike.

Also WingConnect has a description with pictures http://www.wingconnect.com/Garage.html# ... er_install that might help you more than my description.

Gary

Re: troubleshooting left back speaker - no sound

Posted: Fri Jul 07, 2017 1:31 pm
by Toyman9
Thanks Gary, I had tried to get the speaker working but will have to look more at the link you sent. I had gotten pull in to something else at work and now I will have sometime to check it out.

Gregg