side stand switch not working, starts in gear


Information and questions on GL1800 Goldwings (2001-2017)
  • Sponsored Links
Post Reply
User avatar
hotrodpearl
Posts: 35
Joined: Thu Mar 14, 2013 10:35 pm
Location: Calgary, Alberta, Canada
Motorcycle: 2002 gl1800A 1998 Shadow Ace Tourer

side stand switch not working, starts in gear

Post by hotrodpearl » Wed Jun 20, 2018 11:35 pm



I have a problem with my side stand safety switch. When the side stand is put in the down position , the S light comes on on the dash as it should but it's still will start in gear with the clutch in or out and also when the bike is running the side stand will not kill the engine if it's put in gear. Reverse also works with the side stand down and it shouldn't. Anybody got any ideas? Hopefully it's just the switch and not a wiring issue but it seems strange that the S light on the dash still comes on. thanks for any ideas



User avatar
hotrodpearl
Posts: 35
Joined: Thu Mar 14, 2013 10:35 pm
Location: Calgary, Alberta, Canada
Motorcycle: 2002 gl1800A 1998 Shadow Ace Tourer

Re: side stand switch not working, starts in gear

Post by hotrodpearl » Wed Jun 20, 2018 11:36 pm

2002 gl1800A , 103,000 miles

User avatar
GoldWingrGreg
Posts: 292
Joined: Tue Aug 24, 2010 7:18 am
Location: Zephyrhills, Florida
Motorcycle: 89 GL1500
03 GL1800
04 GL1800(abs)
05 GL1800(abs)
07 GL1800(abs)

Re: side stand switch not working, starts in gear

Post by GoldWingrGreg » Thu Jun 21, 2018 1:53 am

Disconnect the side stand switch 3P connector. Check for continuity between the switch side connector terminals in each side stand position. There should be continuity as follows:

extended - green to yellow/blue
retracted - green to green/white

If not, replace the side stand switch.

User avatar
WingAdmin
Site Admin
Posts: 19678
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: side stand switch not working, starts in gear

Post by WingAdmin » Thu Jun 21, 2018 8:00 am

The switch is a double pole switch. When it is down, it connects the output of the indicator to ground, which lights the indicator. When it is up, it connects the sense line of the ECU to ground, which allows the bike to start/run when shifted into gear.

Side stand switch circuit
Side stand switch circuit

Do the test mentioned above. If the switch tests out good, then it's possible that the green/white wire from the ECU has gotten pinched and shorted to ground somewhere, which will cause the behavior you're describing.

If it is the switch, I have a used one in the online store:

/Store/New-Used- ... owItem=172

Image

User avatar
hotrodpearl
Posts: 35
Joined: Thu Mar 14, 2013 10:35 pm
Location: Calgary, Alberta, Canada
Motorcycle: 2002 gl1800A 1998 Shadow Ace Tourer

Re: side stand switch not working, starts in gear

Post by hotrodpearl » Thu Jun 21, 2018 11:20 pm

Thanks GoldWingrGreg and WingAdmin . checked out the switch and its good so I guess its in the wiring . slight correction on my orig post...… It will NOT start in gear with the clutch out...….. Also the bike did do this once a couple months ago and then when I went to trouble shoot it the sidestand killed the motor every time I tried but now its consistently not working .
I tested for continuity to ground from the plug that comes from the harness and I have continuity to ground from the green wire at all times and also have continuity from the green and white wire at all times. One other slight issue is when riding in heavy rain the ABS light comes on and stays on until bike dries out and then goes off . I don't see how that could be related but I'm just throwing it out there because it's the only other irregularity I have found. When I've been playing with it occasionally it will stumble slightly when I put the kickstand down with it in gear which almost seems like it's trying to kill the motor but doesn't quite manage. Any ideas on where to look 4 a short to the frame on that green and white wire or a workaround possibly from the ECM to the wiring harness plug for the green and white wire. I'm a little uneasy riding it because inevitably one of these times I will drive off with the side stand down.............

User avatar
hotrodpearl
Posts: 35
Joined: Thu Mar 14, 2013 10:35 pm
Location: Calgary, Alberta, Canada
Motorcycle: 2002 gl1800A 1998 Shadow Ace Tourer

Re: side stand switch not working, starts in gear

Post by hotrodpearl » Thu Jun 21, 2018 11:24 pm

Could the ground be feeding back from somewhere else to the ecm……?

User avatar
hotrodpearl
Posts: 35
Joined: Thu Mar 14, 2013 10:35 pm
Location: Calgary, Alberta, Canada
Motorcycle: 2002 gl1800A 1998 Shadow Ace Tourer

Re: side stand switch not working, starts in gear

Post by hotrodpearl » Fri Jun 22, 2018 9:19 pm

Problem solved. Found a pinched wire behind the handlebar wireguide going to the clutch safety switch which overtime had Wore through the insulation and created a constant ground feeding back to the green and white wire. Followed someone's suggestion that I look at some of those areas and fortunately found it. Thanks to all who offered ideas

Techdude2000
Posts: 146
Joined: Mon Jun 13, 2011 10:11 pm
Location: Lexington, KY
Motorcycle: 2004 GL1800

Re: side stand switch not working, starts in gear

Post by Techdude2000 » Fri Jun 22, 2018 9:25 pm

hotrodpearl wrote:
Fri Jun 22, 2018 9:19 pm
Problem solved. Found a pinched wire behind the handlebar wireguide going to the clutch safety switch which overtime had Wore through the insulation and created a constant ground feeding back to the green and white wire. Followed someone's suggestion that I look at some of those areas and fortunately found it. Thanks to all who offered ideas
Glad you found it.



Post Reply