2003 GL1800 Front passagner turn signal not working


Information and questions on GL1800 Goldwings (2001-2017)
Post Reply
Bretts
Posts: 4
Joined: Tue Jun 19, 2018 10:08 pm
Location: Indianapolis Indiana
Motorcycle: 2003 gl100

2003 GL1800 Front passagner turn signal not working

Post by Bretts »



I have changed the bulb I have changed the whole switch out for the handlebars. I have also changed the socket out. :x I am at a loss now. the driver side of the bike works fine. the passenger side is very intermittent if at all. the rear passenger turn works but flashes quick. all accessory turn signal lights on passenger side do not work as well when front is not working. I can hear the relay clicking. Also the indicator light quits working when front light doesn't come on.


I am at a loss please help.


DaveO430
Posts: 1201
Joined: Fri Jan 02, 2015 7:28 pm
Location: Amity. Ar
Motorcycle: 2010 GL1800
2004 Suzuki DR200

Re: 2003 GL1800 Front passagner turn signal not working

Post by DaveO430 »

What do you mean by "accessory turn signal lights"? Does the position light work when the turn signal is off?
Bretts
Posts: 4
Joined: Tue Jun 19, 2018 10:08 pm
Location: Indianapolis Indiana
Motorcycle: 2003 gl100

Re: 2003 GL1800 Front passagner turn signal not working

Post by Bretts »

Yes running light works I have two accessory turn signals hooked up they work when front turn signal works but do not work when front doesn’t work.
DaveO430
Posts: 1201
Joined: Fri Jan 02, 2015 7:28 pm
Location: Amity. Ar
Motorcycle: 2010 GL1800
2004 Suzuki DR200

Re: 2003 GL1800 Front passagner turn signal not working

Post by DaveO430 »

Bretts wrote: Sun Aug 19, 2018 5:10 pm Yes running light works I have two accessory turn signals hooked up they work when front turn signal works but do not work when front doesn’t work.
There is most likely your problem. Go to where they are connected and undo what you did to connect them.
Bretts
Posts: 4
Joined: Tue Jun 19, 2018 10:08 pm
Location: Indianapolis Indiana
Motorcycle: 2003 gl100

Re: 2003 GL1800 Front passagner turn signal not working

Post by Bretts »

Already tried that no change. And the extra turn signals have been on the bikes for years.
User avatar
GoldWingrGreg
Posts: 811
Joined: Tue Aug 24, 2010 7:18 am
Location: Zephyrhills, Florida
Motorcycle: 89 GL1500
03 GL1800
04 GL1800(abs)
05 GL1800(abs)
07 GL1800(abs)
Contact:

Re: 2003 GL1800 Front passagner turn signal not working

Post by GoldWingrGreg »

I can never remember what symptoms match what problem. However I believe you are describing a bad connection under the seat. The connection probably has burnt wires (green/red tracer) in it. The red arrow points to the connector. However the picture is taken from an 2005 trike. Your connecter will probably be located in the red circle area. I think the connector has 21 wires going through it. Your connector color might be black. As with the one pictured, yours will also be in a large black boot. Hopefully this helps.
Attachments


Techdude2000
Posts: 341
Joined: Mon Jun 13, 2011 10:11 pm
Location: Lexington, KY
Motorcycle: 2004 GL1800

Re: 2003 GL1800 Front passagner turn signal not working

Post by Techdude2000 »

Bretts wrote: Sat Aug 18, 2018 10:37 am I have changed the bulb I have changed the whole switch out for the handlebars. I have also changed the socket out. :x I am at a loss now. the driver side of the bike works fine. the passenger side is very intermittent if at all. the rear passenger turn works but flashes quick. all accessory turn signal lights on passenger side do not work as well when front is not working. I can hear the relay clicking. Also the indicator light quits working when front light doesn't come on.


I am at a loss please help.
Check for corrosion in C8. Rain dripping from the vent above can cause lots of problems in the under pocket fairing connectors. Look especially at the light blue wire, it’s the turn signal wire that feeds the front bulb and the dash indicator for the right side of the bike.


Post Reply