2012: Radio, Turn Signals, Reverse and Key Fob do not work!


Information and questions on GL1800 Goldwings (2001-2017)
Post Reply
User avatar
kc10fe
Posts: 14
Joined: Sun Aug 30, 2015 6:59 pm
Location: Delanco, New Jersey
Motorcycle: 2012 Honda Goldwing 1800

2012: Radio, Turn Signals, Reverse and Key Fob do not work!

Post by kc10fe »



I have a 2012 Wing with comfort, no navi nor XM, and I jumped on to ride the other day and I noticed initially that my key fob would not unlock my trunk or side bags. After I cranked it up I realized on my LCD I had no radio. The clock worked fine and the initial Goldwing emblem came on when turning the key to on, but no radio. I went on to discover that the turn signals do not work and I have no reverse. Everything else works fine that I can tell. All the lights work, the high beams work, the horn works, the bike cranks and runs nicely. I recently installed the DYNAMIC SEQUENTIAL LED TURN SIGNALs and the GL1800/F6B - LED HEADLIGHT KIT from SOCALMOTOGEAR and I have had no issues. The running lights in the DYNAMIC SEQUENTIAL LED TURN SIGNALS do work, I just have no turn signals. I even rode it home after I discovered all the little nuances that had suddenly quit working and she ran great. The battery is putting out 12.6 volts and I checked all the fuses on the left-hand side and the only one I found blown was the BATTERY Fuse and I replaced that and still ended up with all the same issues. The only fuse I didn't check was the MAIN FUSE B/POWER AMP FUSE, and to be quite honest I am not sure how to remove it? I tried disconnecting the battery and letting it sit a day and still no luck. I am looking for any suggestions/recommendations?



DaveO430
Posts: 1201
Joined: Fri Jan 02, 2015 7:28 pm
Location: Amity. Ar
Motorcycle: 2010 GL1800
2004 Suzuki DR200

Re: 2012: Radio, Turn Signals, Reverse and Key Fob do not work!

Post by DaveO430 »

Does the suspension adjust work? Try a new fuse #25, might fix the radio/turn signal problem or it could be the accessory relay but reverse is probably something else.

Techdude2000
Posts: 326
Joined: Mon Jun 13, 2011 10:11 pm
Location: Lexington, KY
Motorcycle: 2004 GL1800

Re: 2012: Radio, Turn Signals, Reverse and Key Fob do not work!

Post by Techdude2000 »

kc10fe wrote:
Fri May 24, 2019 12:07 pm
I have a 2012 Wing with comfort, no navi nor XM, and I jumped on to ride the other day and I noticed initially that my key fob would not unlock my trunk or side bags. After I cranked it up I realized on my LCD I had no radio. The clock worked fine and the initial Goldwing emblem came on when turning the key to on, but no radio. I went on to discover that the turn signals do not work and I have no reverse. Everything else works fine that I can tell. All the lights work, the high beams work, the horn works, the bike cranks and runs nicely. I recently installed the DYNAMIC SEQUENTIAL LED TURN SIGNALs and the GL1800/F6B - LED HEADLIGHT KIT from SOCALMOTOGEAR and I have had no issues. The running lights in the DYNAMIC SEQUENTIAL LED TURN SIGNALS do work, I just have no turn signals. I even rode it home after I discovered all the little nuances that had suddenly quit working and she ran great. The battery is putting out 12.6 volts and I checked all the fuses on the left-hand side and the only one I found blown was the BATTERY Fuse and I replaced that and still ended up with all the same issues. The only fuse I didn't check was the MAIN FUSE B/POWER AMP FUSE, and to be quite honest I am not sure how to remove it? I tried disconnecting the battery and letting it sit a day and still no luck. I am looking for any suggestions/recommendations?
Did the battery fuse blow again after you replaced the fuse? Is the clock keeping the correct time while the key is off? Does your neutral light work? What does it do when you try reverse? Do the hazard lights work? Don’t worry about the power amp fuse, it would only kill your amp.

User avatar
Asphaltmaniac
Posts: 271
Joined: Wed Oct 11, 2017 11:57 am
Location: Sparks Nevada
Motorcycle: 1977 Honda 550K. Sold.
1986 1200 Aspencade. Purchased as a non current brand new in the box 1988. Sold.
2006 1800 Goldwing
2017 BMW 1200 GS Adventure...

Re: 2012: Radio, Turn Signals, Reverse and Key Fob do not work!

Post by Asphaltmaniac »

Have you looked at the wires that run along side the trunk hinges? The constant open and closing of the trunk really does a number on them over time.

User avatar
kc10fe
Posts: 14
Joined: Sun Aug 30, 2015 6:59 pm
Location: Delanco, New Jersey
Motorcycle: 2012 Honda Goldwing 1800

Re: 2012: Radio, Turn Signals, Reverse and Key Fob do not work!

Post by kc10fe »

Thanks everyone for the reply! It turned out to be the LED flasher relay went bad! At least that's what fixed the turn signal issue. I am not sure what blew the BATT circuit breaker, but I replaced it and it hasn't blown again. I am still chasing a light issue with an LED running light, but the radio, reverse, key fob and turn signals are all back in working order! I'll keep you posted if I run into any more problems within this same issue.



Post Reply