Information display


Information and questions on GL1800 Goldwings (2001-2017)
  • Sponsored Links
Post Reply
Garyml469
Posts: 2
Joined: Sat Sep 14, 2019 8:19 pm
Location: Canyon, texas
Motorcycle: 2006 gl1800

Information display

Post by Garyml469 » Tue Sep 17, 2019 6:13 am



I recently bought a 06 1800gl from a dealer. After getting it home I tried to set the clock and reset the trip meter but was unable to. The info button, the set button, the dim button, and trip button are not working. The display of the clock and trip meter are working. Any suggestions for a fix? The dealer did put a new battery in it, could there be a connection to the problem?



User avatar
Wingsconsin
Posts: 980
Joined: Tue Jul 10, 2012 1:47 pm
Location: Sussex, Wisconsin (West of Milwaukee)
Motorcycle: Current Rides -
2002 GL1800 - Pearl Orange
2003 GL1800 - Illusion Blue
1983 Suzuki GS850GL - Blue & Black

Past rides -
1996 GL1500 Aspencade - Pearl Blue
1992 GL1500 Aspencade -Candy Red
1980 GL1100 - Custom Cobalt Blue
1985 GL1200 Aspencade Brown
1983 CX500 Custom Red
1982 CX500 Custom Blue
1978 CX500 Standard Black
1982 Suzuki GS650 Red
Contact:

Re: Information display

Post by Wingsconsin » Tue Sep 17, 2019 10:53 am

I think the '06 is the same as my '02 and my sons '03
The 'bridge' piece from the audio unit to the display panel (meter panel) has a plug that connects the bridge to the bike and the display
I think those buttons are controlled through that plug -
If they disconnected it for some reason ..and forgot to plug it back -- ?
Postings are my opinions based on experience and acquired knowledge.
Your results may vary. Universal disclaimers apply.


Motorcycle Adventure Storys
http://neverlost-justexploring.blogspot.com/

Garyml469
Posts: 2
Joined: Sat Sep 14, 2019 8:19 pm
Location: Canyon, texas
Motorcycle: 2006 gl1800

Re: Information display

Post by Garyml469 » Sun Sep 22, 2019 5:21 pm

Thanks for the info. It was the display meter plug. They left it unplugged.

Post Reply