Bad radio reception GL1800 2007


Information and questions on GL1800 Goldwings (2001-2017)
Post Reply
ScoSuz
Posts: 2
Joined: Sat Nov 18, 2017 5:25 pm
Location: marietta, ohio
Motorcycle: 2007 goldwing se

Bad radio reception GL1800 2007

Post by ScoSuz » Sun Feb 02, 2020 9:44 am



Hi All,
Last summer I started getting poor reception from the radio. I pulled the seat and checked the antenna connection and it was good. This past week I had the shelter off for the air filter expecting to find a loose connection to the radio. It was not loose. Since I mainly use XM and am fond of scratching my head, I’m not sure where to look now. Here comes the fun part, I turned the radio on and I don’t know why, but I wrapped my hand around the antenna close to the base at the trunk and voila, all of a sudden, I immediately started getting very good reception. Remove my hand and poof, reception gone. I’m back to scratching the noggin.

Perhaps someone can tell me what’s going on?

Thanks in advance,
Scott in SE Ohio.



User avatar
MikeB
Posts: 2732
Joined: Fri Dec 04, 2009 12:54 pm
Location: Tacoma, WA
Motorcycle: 1998 - GL1500 Aspencade.
2017 - GL1800 Audio Comfort
Contact:

Re: Bad radio reception GL1800 2007

Post by MikeB » Sun Feb 02, 2020 4:20 pm

Check for good clean connections on the antenna mount and ground strap.
All the attaching hardware needs to be bright and clean, no thread locking compound or grease.
Make sure the connections in the RCA plugs and jacks (antenna plugs) are clean and shiny.

I would check the resistance between the antenna mast and center pin of the antenna cable but I do not know what the reading should be. I can only assume that the readings should be low there and high between the mast and ground.
MikeB
Tacoma, WA, USA

Post Reply