Radio no work?


Information and questions on GL1800 Goldwings (2001-2017)
Post Reply
User avatar
terrydj
Posts: 20
Joined: Thu Jan 29, 2015 7:26 am
Location: Gold Coast Australia
Motorcycle: 2013 F6B Goldwing

Radio no work?

Post by terrydj »



Well it was working yesterday?

But today its a no go?

Pushed every button more than once and nothing

Everything works great

But no Radio

All help muchly accepted


Sorry I missed your call, but the hairs slicked back and I was Rockin to the Ring Tone
User avatar
AZgl1800
Posts: 2929
Joined: Thu Oct 30, 2008 2:46 pm
Location: Lake Oologah Indian Territory USA
Motorcycle: 2009 Piaggio MP3 250cc https://imgur.com/foGDjgv

'02 GL1800 lives in Dawsonville, GA now.
My son is going to enjoy it for many years to come.

Re: Radio no work?

Post by AZgl1800 »

I already replied to your question in SSGWF forum.

disconnect battery, wait 5-10 minutes, reconnect and it should be okay
~John

2009 Piaggio MP3 250cc

https://i.imgur.com/4SOFPYS.jpg
User avatar
terrydj
Posts: 20
Joined: Thu Jan 29, 2015 7:26 am
Location: Gold Coast Australia
Motorcycle: 2013 F6B Goldwing

Re: Radio no work?

Post by terrydj »

I had the Battery unplugged for 2 hours maybe more with still the same result
No Radio?????
Sorry I missed your call, but the hairs slicked back and I was Rockin to the Ring Tone
waynehere
Posts: 10
Joined: Thu Feb 07, 2013 2:14 pm
Location: Cuba, New York
Motorcycle: 2004 Goldwing 1800

Re: Radio no work?

Post by waynehere »

So I had the similar problem and for my radio when I brought it out of storage. Did some looking on the net and found this site.

https://wingconnect.com/the-garage

Mine was a button sticking. I actually banged on them kind of hard without breaking anything and then it started working. I sent it in to this guy to upgrade my amp and he also cleaned the buttons. But if you have the shop manual, it also helps checking power to the radio too, which I had no problem.

Wish you luck..
Techdude2000
Posts: 484
Joined: Mon Jun 13, 2011 10:11 pm
Location: Lexington, KY
Motorcycle: 2004 GL1800

Re: Radio no work?

Post by Techdude2000 »

terrydj wrote: Fri Apr 09, 2021 3:47 am Well it was working yesterday?

But today its a no go?

Pushed every button more than once and nothing

Everything works great

But no Radio

All help muchly accepted
Is the clock working with the correct time? If not, the “battery” fuse has blown and it will kill the radio too.
User avatar
joeincalif
Posts: 876
Joined: Sat Nov 22, 2014 10:39 am
Location: Fresno, Ca
Motorcycle: 1997 Gold Wing SE

Re: Radio no work?

Post by joeincalif »

Make sure the SEL auto select button is not pushed


Image
IF YOUR BORN ONCE YOU WILL DIE TWICE
IF YOUR BORN TWICE YOU WILL DIE ONCE
Post Reply