Radio No Signs of Life


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
Post Reply
User avatar
aholloway17
Posts: 58
Joined: Sat Jan 28, 2017 10:00 pm
Location: Wallkill, NY
Motorcycle: 1994 GL1500 Interstate

Radio No Signs of Life

Post by aholloway17 » Sat Apr 14, 2018 7:03 pm



So the bike is stored in a bike bag under my deck so it does sit outside in the frigid winter temps. I took the bike out to start getting ready for riding season and that radio does not turn on, nothing nada, zip. I checked three fuses, and verified there is power at the harness. Ideas port should I just send it in?

Thoughts,


1994 GL1500 Interstate

User avatar
Charlie1Horse
Posts: 359
Joined: Mon Sep 16, 2013 9:35 pm
Location: Jacksonville, Florida
Motorcycle: 1986 GL1200A Aspencade
1992 GL1500I Interstate

Re: Radio No Signs of Life

Post by Charlie1Horse » Sat Apr 14, 2018 9:16 pm

If you checked the proper fuses #2-15A, #9- 5A, and #10- 10A and they are all good, remove the radio and disconnect the 18 pin white connector. Test voltage between the green wire(-) and the red/yellow wire (+) and there should be battery voltage at all times. Test voltage between the green wire(-) and the light green/black wire (+) and there should be battery voltage with the ignition in ACC, ON, or P. If these voltages are correct then you will probably have to send the radio to Sierra Electronics for repair. I am having the same issue with my 92 Interstate.
Russell

Those who say it cannot be done should try not to interrupt those who are doing it.

Post Reply