MFI light and lope/die at idle


Information and questions on GL1800 Goldwings (2001-2017)
  • Sponsored Links
Post Reply
donu
Posts: 2
Joined: Thu May 03, 2018 1:17 pm
Location: Rockford, Illinois
Motorcycle: 2004 Goldwing 1800 with Motorvation sidecar.

MFI light and lope/die at idle

Post by donu » Thu May 03, 2018 1:46 pm



My sad story:
Wife bought 2004 Goldwing with side car from father of a friend down in Florida as birthday present for me. Flew down to ride back to Illinois. Battery died in Ocala, went to Batteries Plus, they volunteered to install battery as I was suffering in the heat and humidity. They installed incorrect battery - terminals were reversed. Claimed independent shop I went to for help told them wrong battery number and denied all responsibility. (went to independent shop because Ocala Honda dealer would not look at it). They then installed correct battery but no start. Long story short, 100 amp fuse was blown, 30 Amp fuse was blown. Replaced those, still no start. Further diagnosis found 3 bad relays, replaced those, bike started. MFI light now comes on at 2500 rpm, lopes at idle, sometimes dies at idle. I did manage to make it 1250 miles back to Illinois. Took to local Honda dealer who has had it now for 7 weeks, unable to repair and has given up. Has had factory rep look at it - claims for 5 hours. Says codes indicate knock sensors, replaced them, no change. They did discover one wire to knock sensor with no continuity, replaced, no change. New ECM, no change. Switched out replacement relays and some diodes(?), no change.
Does any one have any idea as to what can be done to cure this?



User avatar
GoldWingrGreg
Posts: 226
Joined: Tue Aug 24, 2010 7:18 am
Location: Zephyrhills, Florida
Motorcycle: 89 GL1500
03 GL1800
04 GL1800(abs)
05 GL1800(abs)
07 GL1800(abs)

Re: MFI light and lope/die at idle

Post by GoldWingrGreg » Sun May 06, 2018 8:02 am

From here it sounds like Battery's Plus was color blind, or had not taken the "online coarse" about red going to positive and black going to negative, and that your battery was hooked up wrong.

As for Honda replacing the knock sensor wire, that's a shielded wire and hopefully they replaced it with a shielded wire. A shielded wire is like coax cable. The inner wire is shielded from outside interference by the outer metal shield.

If I recall, when a battery is connected incorrectly on a GL1800 4 relays need replaced. For better assistance, send Techdude2000 a PM. He has the patients and knowledge to walk you all the way through your problem to a resolution. He visits and posts here, but not real frequently.

donu
Posts: 2
Joined: Thu May 03, 2018 1:17 pm
Location: Rockford, Illinois
Motorcycle: 2004 Goldwing 1800 with Motorvation sidecar.

Re: MFI light and lope/die at idle

Post by donu » Sun May 06, 2018 10:09 pm

Thank you so much for your reply. Apparently,batteries plus used wrong battery initially, like 20l vs 20 r, same size etc but poles reversed. Of course, they blamed used bike shop I stopped at when Ocala Honda dealer would not trouble them selves to assist a guy 1300 miles from home. Their parts department was of no help either when needed relays. Can not begin to express my opinion of this dealership, would love to see Honda pull franchise from these jerks.
Will reach out to person you recommend, hopefully he has some insight that local dealer and his Honda rep can not provide.
Again, much thanks.

DaveO430
Posts: 878
Joined: Fri Jan 02, 2015 7:28 pm
Location: Amity. Ar
Motorcycle: 2010 GL1800
2004 Suzuki DR200

Re: MFI light and lope/die at idle

Post by DaveO430 » Mon May 07, 2018 6:53 am

I got a new battery online and the poles were reversed and not marked. Fortunately I tested it before installing it.

User avatar
wing rider 2012
Posts: 225
Joined: Thu May 16, 2013 4:49 pm
Location: Medford, Oregon
Motorcycle: 2012 GL1800 Level I Blue/Silver
1998 GL1500 Aspy
1985 Venture Royal 1300
1979 GL1000

Re: MFI light and lope/die at idle

Post by wing rider 2012 » Sat May 12, 2018 1:44 pm

I'm wondering if it could be related to the Crank Shaft Position sensor or the Cam Shaft Position sensors, if your MFI light comes on with an increase in RPM, the 2 could be related.


Vietnam Veteran
9th ID, Jan 69 - Oct 70
Member: Military Order of the Purple Heart
Member: Vietnam Veterans of America
Member: GWTA. Chapter A, Grants Pass, Oregon

Post Reply