LCD. Clock and pressure is showing, but not radio


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
Post Reply
Zekyze
Posts: 2
Joined: Sun Jul 08, 2018 2:49 pm
Location: Sweden
Motorcycle: GL 1500 SE

LCD. Clock and pressure is showing, but not radio

Post by Zekyze » Sun Jul 08, 2018 3:09 pm



Hello everybody!

I am new owner of GL 1500 SE m.y. 1990.
Before this, I was driving Electra Glide, K1100 LT.
Here is my "litlle" worries (problem):
LCD shows time and pressure in rear shocks. But upper part of LCD is "dead". Radio is working, tape also, all knobes are in the function... but nothing on upper part of LCD.


Maybe this info will help you to give me guidelines:

Since this is my first GL 1500, one week after purchase I have noticed that rear speakers and "fader" potentiometer are missing.

Is there somebody to tell me where should I start troubleshooting?

Regards from Sweden



User avatar
WingAdmin
Site Admin
Posts: 19404
Joined: Fri Oct 03, 2008 4:16 pm
Location: Strongsville, OH
Motorcycle: 2000 GL1500 SE
1982 GL1100A Aspencade (sold)
1989 PC800 (wife's!)
1998 XV250 Virago (sold)
2007 Aspen Sentry Trailer

Re: LCD. Clock and pressure is showing, but not radio

Post by WingAdmin » Mon Jul 09, 2018 8:31 am

Zekyze wrote:
Sun Jul 08, 2018 3:09 pm
Hello everybody!

I am new owner of GL 1500 SE m.y. 1990.
Before this, I was driving Electra Glide, K1100 LT.
Here is my "litlle" worries (problem):
LCD shows time and pressure in rear shocks. But upper part of LCD is "dead". Radio is working, tape also, all knobes are in the function... but nothing on upper part of LCD.


Maybe this info will help you to give me guidelines:

Since this is my first GL 1500, one week after purchase I have noticed that rear speakers and "fader" potentiometer are missing.

Is there somebody to tell me where should I start troubleshooting?

Regards from Sweden
The LCD is driven by two separate systems. The lower half (click and air pressure) is controlled by the circuit mounted to the back of the LCD. The upper half (radio, etc.) is driven by the radio itself. I would start by checking the connectors between the radio and the LCD to make sure they are seated properly, and without corrosion.

There are three of them: C2, which is the connector on the radio itself.

C71 is behind the left fairing pocket:

C71
C71

C91 is on the back of the instrument panel:

C91
C91


Rambozo
Posts: 4
Joined: Sun Apr 01, 2018 8:36 pm
Location: Disneyland
Motorcycle: 1992 GL1500 Aspencade

Re: LCD. Clock and pressure is showing, but not radio

Post by Rambozo » Tue Jul 10, 2018 6:52 am

Rear speakers and fader were optional. You can get a kit to add them for bikes that don't have them.

Zekyze
Posts: 2
Joined: Sun Jul 08, 2018 2:49 pm
Location: Sweden
Motorcycle: GL 1500 SE

Re: LCD. Clock and pressure is showing, but not radio

Post by Zekyze » Thu Jul 12, 2018 12:34 pm

Wingadmin, Rambozo, thanks for your answers.

Wingadmin, thank you very much for advice.
The problem was C2 on radio. Someone was there before me and havent pushed connector C2 all way in.

Now it is working! :D :D :D

Wish that I can uppload and you download one cold beer!
Thanks one more time!

Regards from Sweden.

User avatar
Bluewaterhooker0
Posts: 964
Joined: Wed Nov 14, 2012 11:27 pm
Location: Tampa, Fl
Motorcycle: 1997 Goldwing GL 1500 SE

Re: LCD. Clock and pressure is showing, but not radio

Post by Bluewaterhooker0 » Thu Jul 12, 2018 2:45 pm

Zekyze wrote:
Thu Jul 12, 2018 12:34 pm
Wingadmin, Rambozo, thanks for your answers.

Wingadmin, thank you very much for advice.
The problem was C2 on radio. Someone was there before me and havent pushed connector C2 all way in.

Now it is working! :D :D :D

Wish that I can uppload and you download one cold beer!
Thanks one more time!

Regards from Sweden.
WOW !!!
I think you may be on to something !
Buying a virtual drink for your buddies online. What an idea.
This is the next Amazon in the making. I need to think on this one. Where's my beer ?



Post Reply