Radio not working


Information and questions on GL1500 Goldwings (1988-2000)
  • Sponsored Links
Post Reply
wcourtois
Posts: 5
Joined: Mon Jun 10, 2019 6:37 am
Location: United States
Motorcycle: 1999 gl1500

Radio not working

Post by wcourtois » Fri Sep 06, 2019 5:50 pm



Sorry, I know there many threads about radio issues. But, I can't seem to find one with my exact issue. My radio didn't turn one day after work and still isn't. I replaced the blown 5a fuse but no change. There's an icon on the display that I can't find any info about.





User avatar
DenverWinger
Posts: 1035
Joined: Thu Jun 23, 2011 2:20 pm
Location: Denver, CO
Motorcycle: (s)
1980 GL1100 STD Vetter (2005-)
1993 GL1500 Aspencade (2017-)
1983 Trav-Lite Camper (2010-)
Past rides
1972 CL350 (1980-1988) sold
1978 Suzuki GS550 (1985-2005) sold
1977 GL1000 (2002-2006) sold

Re: Radio not working

Post by DenverWinger » Fri Sep 06, 2019 6:08 pm

That's the icon in the display you get when the cassette tape player is selected and there's no tape in the deck. The upper left button on the radio will switch it back to radio operation.
♫ 99 Little Bugs in the Code, ♪
♪ 99 Bugs in the Code. ♫ :(
♫ Take one down, Patch it around, ♪
♫ 127 Little Bugs in the Code. ♫ ♪ :shock:

~Mark

wcourtois
Posts: 5
Joined: Mon Jun 10, 2019 6:37 am
Location: United States
Motorcycle: 1999 gl1500

Re: Radio not working

Post by wcourtois » Sun Sep 08, 2019 9:45 am

Well I feel like an idiot, but thankfully it was that simple. I was sure when I found the blown fuse it was something more. Thank you!

Post Reply